How to obtain initial support information from Novell Identity Manager.

2009-09-10

  • Novell Identity Manager

Summary

It may be necessary for technical support to ask for detailed logs from an IDM system which is exhibiting undesired results or is completely failing to sync accounts from one system to another.

Symptoms

Technical Support have asked for IDM traces

Cause

The issue described required detailed logs.

Question

How do I obtain these logs?

Answer

How to obtain initial support information from Novell Identity Manager.

First of all, there are some specifics to be aware of.

eDirectory Driver:
This consists of two drivers, so there is one driver in the "vault" and another driver in the connected

eDirectory tree. Both drivers need to be configured independently to obtain trace information. One trace is generally no use without the other.

Remote Loader:
Taking the Active Directory driver as an example here. Most AD drivers have a remote loader running on a

Domain Controller or a Member Server. This is in addition to a driver running on the "vault" end. This means there will be two traces required if the driver is a remote loader. Generally, one trace is not much use without the other.

iManager:
It is best to use iManager to configure the drivers for traces not designer. If iManager is not installed or not accessible, there is a stand-alone version which will run on most windows workstations. The current supported standalone version, iManager 2.7 can be downloaded from Novell:
http://download.novell.com/Download?buildid=7aBB5fT0yiw~
This may need to be patched to SP3, as well as installing the Identity Manager Snapins.
iManager 2.7 sp3:
http://download.novell.com/SummaryFree.jsp?buildid=343knMPJEus~
Depending on the version of Identity Manager you are running, here is the the link to the snapins for IDM 3.6.1:
http://download.novell.com/SummaryFree.jsp?buildid=ioYR53FJcGQ~

General Tracing: Once all the tracing is set up, the operation that fails needs to be performed. We will need to know what fails and the account tested during the tracing. Once the testing is completed, it is suggested the tracing is turned off for busy production systems, to prevent additional issues caused by slowness introduced by logging. Trace level 0 (zero) turns off tracing, using the same steps to enable it.

Now the pre-requisites have been met to obtain the patches and where they need to be obtained from, this is how to export, then configure your drivers for trace collection.

Exporting driver configurations:

Depending on the nature of the issue, either a driver set export or a specific driver export will be asked for.

Exporting the driver set:
> Identity Manager Utilities
>> Export Configuration
>>> Browse to the driver set object, please do not go any lower in to a driver set and select a driver.
>>> Next
>>> Leave the settings at default. So it should be:

"Export all contained policies"
Copy external policies into exported drivers = Yes
Export provisioning objects = Yes
>>> Next
Then you should see a "Please Wait" banner, while the export is working. This can take a few minutes.
>>> Save As
>>> Save the resulting XML file.
Please Zip this file, then send it to us, identifying which driver set this is.

Exporting a specific driver:
> Identity Manager Utilities
>> Export Configuration
>>> Browse to the driver set object,
>>> Browse to the specific driver and select it.
>>> Next
>>> Leave the settings at default. So it should be:

"Export all contained policies"
Copy external policies into exported drivers = Yes
Export provisioning objects = Yes
>>> Next
Then you should see a "Please Wait" banner, while the export is working. This can take a few minutes.
>>> Save As
>>> Save the resulting XML file.
Please Zip this file, then send it to us, identifying which driver this is.

Remote Loader Tracing:
The example here, refers to the Active Directory remote loader, on Windows.
Connect to the console of the server where the remote loader shim is running. Please note, if using

Remote Desktop or "mstsc.exe", please ensure the syntax used is "mstsc.exe /console" otherwise it will

not be possible to configure debug mode on the remote loader due to security restrictions in Windows.
> Start the "Identity Manager Remote Loader Console" - usually placed on the desktop.
>> Select the remote loader instance in question, then stop the instance.
>> Edit
>>> At the bottom of the window, there is a Trace File section, please enter a setting of 5, or whatever

other value we have requested.
>>> Enter a file name on a disk where there is known to be a large amount of free space.
>>> If setting the log size limit is desired, please set this to a minimum of 100mb.
>> Ok
>> Start
A debug windows should appear, waiting for the driver to connect.
- Please remember, the remote loader has a driver end as well in the vault, so please also take a trace there, as described at the top of this document.

Driver Tracing:

> Identity Manager
>> Identity Manager Overview
>>> Click on Search without changing the default location to search
The driver set for the tree you are logged in to should be displayes.

To enable logging:
>> Click on the driver icon concerned
>> Click on the Green Light of the driver icon, select stop driver. If it's already stopped, please continue with this anyway.
>> Click on the driver icon in the next display, a new window opens
>> Click on Misc under the Identity Manager tab
>> Set the Trace Level to 5, or what ever other value we have asked you to enter.
>> Set the trace file to use a path according to the operating system where the driver engine is located.

A directory for the logs may need to be created, please check it exists, otherwise logging may fail.

so examples for:
linux /opt/novell/idm/log/addriver.log
netware sys:system\idmlogs\addriver.log
windows c:\novell\idm\logs\addriver.log

Please name the log file according to the driver name to make finding log files simpler.

Please note, the above refers to where the IDM engine and driver is running, for example the IDM Vault Server, regardless if you have a remote loader, we will cover the remote loader separately.

the trace file limit should be set to 100Mb, please ensure there is more space than this on the drive you are logging to. Please note, the log file setting 100mb will create 10 log files of 10mb, called .log (which is the most recent/current log file), followed by _1.log to _9.log. We may require all these logs. It is a good idea to delete these before starting a new logging session.

You can enter in the trace name nothing, or anything short which may help reading the trace, such as the driver name etc.

>>> Apply, OK. The window will close.
>>> Start the driver.
- Please remember, if the driver is a remote loader, the trace at the connected system is also needed, as described at the top of this document.

Solution

the above detailed description advises how to obtain the necessary logs using iManager.
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